Nueva vulnerabilidad de escalada de privilegios en Cisco Webex

La vulnerabilidad puede ser explotada sólo por usuarios locales

Hackers maliciosos podrían explotar una vulnerabilidad en Cisco Webex Meetings para sistemas operativos Windows para elevar sus privilegios y ejecutar comandos arbitrarios usando los privilegios de administrador, reportan especialistas en seguridad en redes del Instituto Internacional de Seguridad Cibernética.

Esta vulnerabilidad afecta a todas las versiones de la aplicación Cisco Webex Meetings para equipos de escritorio entre 33.6.4.15 y 33.8.2.7, aunque los expertos no descartan la posibilidad de que versiones anteriores también sean afectadas por esta vulnerabilidad.

La vulnerabilidad (CVE-2019-1674) es una inyección de comandos en el sistema operativo pensada para esquivar las nuevas medidas de seguridad  de Cisco, implementadas después de corregir un problema de secuestro de DLL encontrado en la misma aplicación anteriormente.

Acorde a los expertos en seguridad en redes, CVE-2019-1674 existe debido a la incapacidad del servicio de actualización de Webex para Windows para validar adecuadamente los números de versión de los nuevos archivos. Atacantes locales sin privilegios podrían explotar la vulnerabilidad invocando el comando de servicio de actualización con un comando especialmente diseñado.

Los hackers maliciosos podrían explotar esta vulnerabilidad reemplazando el binario de la actualización de esta aplicación con una versión anterior usando la técnica de falsa actualización de software. Posteriormente se genera la escalada de privilegios y los hackers ejecutan comandos arbitrarios con privilegios de administrador.

Esta no es la primera ocasión que expertos en seguridad en redes encuentran vulnerabilidades en esta herramienta, aunque no es considerada tan severa como la vulnerabilidad conocida como WebExec, que permite a los atacantes ejecutar comandos de forma remota a través de un componente de una versión vulnerable de Webex.

(Visited 238, 1 times)