WordPress 4.4 y PHP 7.0 afectados por un fallo de seguridad 0-day

Conocimiento pertenece al mundo
Tweet about this on TwitterShare on FacebookShare on LinkedInShare on Google+Share on StumbleUponShare on TumblrShare on RedditPin on PinterestEmail this to someone

WordPress es el CMS más utilizado de todo el mundo. El mayor número de páginas web creadas tanto por empresas como por usuarios convencionales utilizan este CMS debido a su precio (gratuito) y a su naturaleza OpenSource que permite a los administradores y desarrolladores personalizar hasta el más mínimo detalle de sus páginas web. Sin embargo, al ser una herramienta tan extendida también es un objetivo interesante para los piratas informáticos, quienes buscan constantemente nuevas formas de aprovecharse de esta plataforma.

No es la primera vez que WordPress se ve afectado por un fallo de seguridad, y tampoco será la última. En esta ocasión ha sido la versión más reciente, la 4.4, quien se ha visto afectada por un fallo de seguridad del tipo Full Path Disclosure, es decir, puede permitir a un atacante obtener la ruta absoluta de todos los ficheros de la web en cuestión.

WordPress 4.4 y PHP 7.0 afectados por un fallo de seguridad 0-day

Aunque por sí misma esta vulnerabilidad no supone ningún peligro (solo permitiría saber a un atacante la ruta absoluta de los archivos dentro del servidor), sí que puede ser utilizada para llevar a cabo otros ataques como el uso de load_file () en un SQL Injection, donde se necesita la ruta absoluta para poder obtener el código fuente de una página web.

Por el momento, esta vulnerabilidad aún no ha sido registrada y mucho menos solucionada, sin embargo, ya cuenta con un exploit disponible para todos aquellos usuarios interesados en comprometer la seguridad de un servidor WordPress.

A la venta exploits que se aprovechan de esta vulnerabilidad en WordPress 4.4

Lejos de facilitar más detalles sobre la vulnerabilidad, varios hackers han creado ya exploits que permiten aprovecharse de ella. Estos exploits muestran la ruta absoluta del exploit vulnerable y facilitan también 3 ejemplos sobre cómo explotarlo para aprovecharse de él.

El precio de este exploit es de 30 dólares que, teniendo en cuenta que se trata de una vulnerabilidad de día cero que aún no está solucionada, es un precio bastante reducido para las posibilidades que ofrece.

PHP 7.0 también afectado por un fallo de seguridad

WordPress no es el único software afectado por fallos de seguridad hoy. La versión más reciente de PHP, 7.0, también se ha visto afectada por un fallo zero-day en las últimas horas. En esta ocasión, el fallo de seguridad es del tipo Format String Attack, un fallo que hace que el servidor considere el valor de un string como un comando, de manera que se puedan llevar a cabo ataques de ejecución de código remoto o un fallo de segmentación, entre otros tipos de ataques.

Por el momento no se ha publicado ningún informe sobre la vulnerabilidad ni ningún parche que lo solucione, sin embargo, sí que existe un exploit para aprovechar este fallo de seguridad en PHP 7.0. Este se puede conseguirse en la red de forma totalmente gratuita, lo que aumenta su peligrosidad.

Es recomendable mantener siempre el software actualizado con los últimos parches de seguridad ya que, aunque por el momento las vulnerabilidades sean de tipo zero-day, los responsables de ambas plataformas no tardarán en publicar un parche que las solucione.

Fuente:http://www.redeszone.net/

Conocimiento pertenece al mundo
Tweet about this on TwitterShare on FacebookShare on LinkedInShare on Google+Share on StumbleUponShare on TumblrShare on RedditPin on PinterestEmail this to someone