Una vulnerabilidad en Graphite afecta a Linux, OpenOffice y Firefox entre otros

Conocimiento pertenece al mundo
Tweet about this on TwitterShare on FacebookShare on LinkedInShare on Google+Share on StumbleUponShare on TumblrShare on RedditPin on PinterestEmail this to someone

Muchas veces la seguridad de un sistema operativo no depende solo del usuario sino que al disponer de librerías de terceros está expuesto a que alguna de estas sufra un problema que afecte al equipo. En esta ocasión ha sido Graphite, librería encargada del procesamiento de fuentes, la que posee cuatro vulnerabilidades que podrían permitir el control remoto del equipo.

El problema es que se trata de una librería muy utilizada no solo por el propio sistema operativo, sino también por otras aplicaciones. Sin ir más lejos, el navegador Firefox, el cliente de correo Thunderbird, OpenOffice y LibreOffice, WordPad o Pale Moon son un ejemplo de la cantidad de aplicaciones que hacen uso de esta y que por lo tanto están igualmente afectadas. Además de servir como intérprete para las fuentes, posee una herramienta que permite crear otras fuentes gracias a un editor gráfico.

Anteriormente hemos mencionado que son cuatro las vulnerabilidades detectadas, pero desde Cisco Talos, los encargados del descubrimiento, han destacado la catalogada como CVE-2016-1521 que podría permitir que un atacante provocase el mal funcionamiento del equipo y la ejecución remota de código.

Seguro que muchos estáis pensando que los usuarios al ignorar la existencia de esta librería también ignoran su uso para atacara al equipo en el caso de sufrir una vulnerabilidad. Si es así no es para nada descabellado, ya que sin ir más lejos, si se hace uso de la cuenta de Graphite incluida por defecto en el navegador web Firefox, el atacante dispondría de un abanico muy amplio de posibilidades para perpetrar el ataque. En el caso del navegador web, esta se ha incluido desde la versión 11, es decir, desde el año 2012.

Desde Cisco creen que los ciberdelincuentes podrían utilizar una página web con un CSS mal formado para llevar a cabo el ataque y utilizar la librería como pasarela para ejecutar código de forma remota en el equipo.

Firefox y un error en Graphite: una mala dupla para la seguridad de los equipos

Nos hemos focalizado en el navegador web de la fundación Mozilla aunque existen otros programas afectados porque este es el único que pone al usuario en contacto con Internet. Tal y como ya conocen la mayoría de los usuarios, las páginas web poseen una doble finalidad, sirviendo para informar al usuario y servir de ayuda o bien para distribuir malware.

Si el usuario accede a una página web que posee la fuente maliciosa esta permitirá le ejecución de código en el equipo y permitir la descarga de otros archivos que pueden utilizarse contra por ejemplo OpenOffice y LibreOffice.

Los expertos de cisco han probado la versión 2-1.2.4 junto a Firefox 31 y está afectada, no descartando que las versiones anteriores de la librería también lo estén. A finales de enero los responsables de la librería lanzaron la versión 2-1.3.5 pero no se sabe aún si en esta versión se han corregido los 4 problemas de seguridad, o al menos el que permite el control del equipo de forma remota.

Fuente:http://www.redeszone.net/

Conocimiento pertenece al mundo
Tweet about this on TwitterShare on FacebookShare on LinkedInShare on Google+Share on StumbleUponShare on TumblrShare on RedditPin on PinterestEmail this to someone