Los cortafuegos Fortinet comprometidos por un fallo de autenticación SSH

Conocimiento pertenece al mundo
Tweet about this on TwitterShare on FacebookShare on LinkedInShare on Google+Share on StumbleUponShare on TumblrShare on RedditPin on PinterestEmail this to someone

Cuando hablamos de cortafuegos y medidas de seguridad debemos tener en cuenta que no se utilizan los mismos sistemas de protección en entornos domésticos que en grandes empresas y centros de datos. En estos últimos se utilizan equipos especializados, cortafuegos por hardware que controlan todas y cada una de las conexiones que entran y salen por ellos. Mientras que estas medidas de seguridad son mucho más robustas y fiables que los sistemas de seguridad basados en software, ante un fallo de seguridad la información que puede quedar comprometida es mucho más crítica.

Hace algunas horas la seguridad de un gran número de servidores y centros de datos a nivel mundial se ha visto comprometida tras la divulgación de un fallo de seguridad en los cortafuegos de Fortinet. Este fallo de seguridad permite iniciar sesión a través del protocolo SSH en estos sistemas de seguridad con privilegios de administrador utilizando el usuario “Fortimanager_Access” y una contraseña que, aunque no es estática, es sencilla de calcular.

Como siempre hemos dicho, cuando aparece una vulnerabilidad empieza una cuenta atrás entre desarrolladores y piratas informáticos para ser los primeros en crear un exploit o un parche para solucionarlo. En este caso, cuando se ha hecho pública la vulnerabilidad ya existía un exploit para poder aprovecharla, y lo peor de todo es que este exploit es público, por lo que cualquiera puede acceder a él libremente.

No ha pasado mucho tiempo hasta que los usuarios han querido comprobar si de verdad es posible iniciar sesión de forma remota en estos cortafuegos y, demostrando la debilidad, se han publicado varias imágenes garantizando el inicio de sesión.

Fortigate OS - SSH Backdoor

Fortinet, su sistema operativo FortiOS y los firewalls Fortigate son muy utilizados en todo el mundo para proteger redes y centro de datos y, aunque esto puede suponer una grave brecha de seguridad a nivel mundial, es posible que el fallo no sea totalmente responsabilidad de Fortinet.

Fortinet asegura que no se trata de una vulnerabilidad, sino de un simple problema de autenticación

Los responsables de seguridad de Fortinet no se han quedado en silencio tras las duras críticas que están recibiendo a través de la red. Por ello, en su página web principal, han publicado un informe donde informan de que la vulnerabilidad a la que se está haciendo referencia ya fue identificada internamente y solucionada en 2014, e indican que no fue una puerta trasera, sino que más bien se trataba de un simple problema con  la autenticación.

Como hemos dicho, esta vulnerabilidad afecta a todas las versiones de Fortigate, desde 4.x hasta 5.0.7, sin embargo, tanto la versión 4.3.17 FortiOS como la 5.0.8 están disponibles desde julio de 2014, por lo que, a fin de cuentas, si el usuario utiliza versiones obsoletas no es culpa de la compañía. Cualquier usuario con una versión igual o superior a las dadas estará protegido de esta vulnerabilidad.

Fuente:http://www.redeszone.net/

Conocimiento pertenece al mundo
Tweet about this on TwitterShare on FacebookShare on LinkedInShare on Google+Share on StumbleUponShare on TumblrShare on RedditPin on PinterestEmail this to someone