Desvelan la información técnica sobre Badlock, la vulnerabilidad de Samba

Conocimiento pertenece al mundo
Tweet about this on TwitterShare on FacebookShare on LinkedInShare on Google+Share on StumbleUponShare on TumblrShare on RedditPin on PinterestEmail this to someone

Hace 3 semanas, uno de los responsables del desarrollo de Samba, protocolo de intercambio de archivos multiplataforma desarrollado para facilitar la comunicación entre Windows, Linux y Mac OS X, informaba de la existencia de una vulnerabilidad crítica en el protocolo SMB/CIFS, denominada como Badlock. Esta vulnerabilidad podía comprometer la seguridad de las conexiones que se realizaran a través de él y, por motivos de seguridad, ni los responsables de Samba ni Microsoft han dado ninguna información sobre la vulnerabilidad, la cual ha permanecido totalmente en secreto, hasta hoy.

badlock

Tras una larga espera, hoy, día 12 de abril, finalmente los responsables de la compañía han facilitado información sobre dicha vulnerabilidad crítica en el protocolo. Esta vulnerabilidad ha recibido el identificador CVE-2016-2118, aunque Badlock también hace uso de otras varias vulnerabilidades registradas como:

  • CVE-2015-5370
  • CVE-2016-2110
  • CVE-2016-2111
  • CVE-2016-2112
  • CVE-2016-2113
  • CVE-2016-2114
  • CVE-2016-2115

El uso conjunto de estas vulnerabilidades puede permitir a un atacante realizar ataques MITM para capturar el tráfico entre el cliente y el servidor o ataques DoS para dejar sin servicio a los usuarios.

Las versiones afectadas (prácticamente todas) son: 3.6.x, 4.0.x, 4.1.x, desde la 4.2.0 a la 4.2.9, desde la 4.3.0 a la 4.3.6 y la 4.4.0.

Según CVSS, la vulnerabilidad ha sido considerada como de gravedad alta, con una nota de 7.1 sobre 10.

Badlock aún no está siendo explotado ya que se han guardado en secreto las vulnerabilidades responsables desde su descubrimiento, sin embargo, es muy probable que a partir de este momento los piratas informáticos empiecen a desarrollar exploits que se encarguen de ello. Para evitar que esto ocurra, es recomendable instalar las versiones más recientes de Samba (4.2.11, 4.3.8 y 4.4.2) y actualizar nuestro sistema operativo para evitar que estos fallos puedan ser aprovechados.

Los responsables de seguridad de Samba han actualizado la página web oficial de Badlock con más información sobre esta vulnerabilidad, así como con algunas configuraciones para que los administradores puedan mitigarlas.

Debemos actualizar Samba en todos los sistemas operativos lo antes posible para protegernos de Badlock

El pasado 22 de marzo se liberó una nueva versión de Samba, la 4.4.0. Junto a ella, los responsables del desarrollo finalizaron el soporte para la versión 4.1 y para todas las anteriores, por lo que las únicas versiones de Samba que van a ser actualizadas para solucionar Badlock son la 4.2, 4.3 y 4.4. Los usuarios que aún utilicen una versión anterior de esta plataforma deberían actualizarla ya que están sin soporte y expuestos a posibles vulnerabilidades.

Como hemos dicho, los usuarios de Windows deben instalar los parches de seguridad de Microsoft a través de Windows Update para proteger el protocolo Samba de este fallo de seguridad. Los usuarios de otros sistemas operativos también deben actualizar sus sistemas desde sus plataformas correspondientes lo antes posible para evitar que esta vulnerabilidad pueda ser explotada en ellos.

Fuente:http://www.redeszone.net/

(Visited 312 times, 1 visits today)
Conocimiento pertenece al mundo
Tweet about this on TwitterShare on FacebookShare on LinkedInShare on Google+Share on StumbleUponShare on TumblrShare on RedditPin on PinterestEmail this to someone