Actualiza OpenVPN cuanto antes para corregir estos dos fallos críticos

Conocimiento pertenece al mundo
Tweet about this on TwitterShare on FacebookShare on LinkedInShare on Google+Share on StumbleUponShare on TumblrShare on RedditPin on PinterestEmail this to someone

OpenVPN es el software más popular utilizado para montar conexiones VPN propias. Gracias a él, podemos conectarnos de forma seguridad y privada a nuestra propia red doméstica o de trabajo, pudiendo acceder así a todos los recursos conectados a ella y navegar, además, con total seguridad desde todo tipo de redes públicas. Sin embargo, para garantizar la máxima seguridad, es necesario tener siempre las versiones más recientes, tanto del cliente como del servidor, para evitar estar expuestos por fallos como los que se acaban de dar a conocer en este software VPN.

Aunque en lo que va de año este software se ha sometido a dos auditorías de seguridad, tanto a nivel de cliente como de servidor, las cuales desvelaron y ayudaron a solucionar distintos fallos de seguridad en el software, parece que a los auditores se les ha pasado por alto dos vulnerabilidades muy graves que han estado poniendo en peligro la seguridad de los usuarios.

Dos vulnerabilidades críticas de ejecución de código remoto descubiertas en OpenVPN gracias a un software Fuzzer

Un Fuzzer es un tipo de software de seguridad pensado para buscar y encontrar vulnerabilidades. Este software se encarga de mandar información aleatoria a las aplicaciones de manera que, si se detecta alguna excepción, nos ayuda a identificar posibles vulnerabilidades de todo tipo, desde Buffer Overflow hasta DoS, SQL Injection, XSS y errores Format String.

Así, un investigador de seguridad es como ha descubierto dos fallos críticos ocultos en OpenVPN. El primero de ellos ha sido registrado como “CVE-2017-7521“, un fallo que reside en la función extract_x509_extension(), función encargada de trabajar con los certificados SSL. Esta vulnerabilidad puede permitir a un usuario registrado en la red crear y enviar un certificado al servidor que lo bloquee o incluso que libere memoria que no debe para permitir enviar código directamente el servidor.

La segunda de las vulnerabilidades, “CVE-2017-7520“, reside en la forma en la que OpenVPN se conecta a un proxy Windows NTLM v2. Así, un ataque MITM entre el servidor VPN y el proxy puede permitir a un atacante bloquear el cliente del usuario que se intenta conectar e incluso robar sus contraseñas.

Las actualizaciones para el servidor y el cliente de OpenVPN ya están disponibles

Como es obvio, estas vulnerabilidades primero se han reportado a los responsables de OpenVPN y, después de haberse solucionado, finalmente se han hecho públicas.

Tanto el servidor como el cliente de OpenVPN han recibido sus correspondientes parches de seguridad. Así, si queremos asegurarnos de que nuestras conexiones VPN están totalmente aseguradas, debemos actualizar cuando antes nuestro software de OpenVPN a las versiones 2.4.3 o 2.3.17, versiones que ya incluyen estos parches de seguridad.

Fuente:https://www.redeszone.net/2017/06/22/vulnerabilidades-criticas-rce-openvpn/

Conocimiento pertenece al mundo
Tweet about this on TwitterShare on FacebookShare on LinkedInShare on Google+Share on StumbleUponShare on TumblrShare on RedditPin on PinterestEmail this to someone
Tags: